Apache, Gentoo üzerinden SVN'ye büyük taahhütte “SSL hata ayrıştırma tlsext”


10

Bu sadece büyük taahhütte olur (başarısız bir taahhütle sonuçlanır):

Apache'de sanal ana bilgisayar yapılandırmasından geri dönme bölümü

   <LimitExcept PROPFIND SEÇENEK RAPORU AL>
      Geçerli kullanıcı gerektir
   </ LimitExcept>
   Dav svn
   SVNYol ​​/ ev / svn /

Tamamlama sonucu:

Dosya verileri aktarılıyor .............................. svn: İşleme başarısız oldu
(ayrıntılar aşağıdadır):
svn: PUT /
'/!Svn/wrk/48583f7d-0e01-410d-8941-33d2ba3574b4/WAP/.../htdocs/images/rt.gif':
SSL anlaşması başarısız oldu: SSL hatası: parse tlsext (https: // ...)

Burada referanslar buldum: http://code.google.com/p/support/issues/detail?id=1395

OpenSSL'nin TLS uzantısıyla derlenmesi gerektiğini belirtiyor, ancak benim durumumda, başlangıçta sadece büyük taahhütlerde hata yapmıyor.

Herhangi bir fikir? Teşekkürler


Bu hata için bir apache httpd bugtracker bileti var mı?
— user28271

Yanıtlar:


7

Bu sorunu yaşamadım, ancak biraz zaman geçirdim ve Apache 2.2.12 veya 13'te tanıtıldığını tespit ettim. Apache yapılandırmanızdaki ALL + SSLv2 + SSLv3 . İkisi de kesin görünmüyordu. İyi şanslar! Umarım bir çözüm bulursun.

http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=2393204


SSLProtocol -ALL + SSLv2 + SSLv3 eklemek de benim için çalıştı.

Değer için, aynı sorun vardı ve yukarıda belirtildiği gibi SSLProtocol -ALL + SSLv2 + SSLv3 eklemek bu sorunu benim için düzeltti.
— Adam Carr

Aynı sorunu Ruby 1.9.3'ten bağlanmaya çalışıyordum. Ruby 1.9.2 ne sebeple olursa olsun bir problem değildi. Ve istemci sertifikası kullanılırken hata hemen gerçekleşti. Benim yapılandırma değiştirme SSLProtocol all -SSLv2için SSLProtocol ALL -SSLv2 -TLSv1benim için sabit konuya.
— aNoble


5

GÜNCELLEME

Http://www.gossamer-threads.com/lists/apache/dev/375633 adresinde arşivlenen bu sorunla ilgili http-dev dizisini okuduktan sonra , bu soruna, istemci tarafı OpenSSL kitaplığındaki bir hata neden olduğu anlaşılıyor SSL Biletlerinin / Kimliklerinin nasıl ele alındığına ilişkin olarak, hatanın neden hemen ortaya çıkmadığını, ancak birkaç saniye ila dakika sürdüğünü açıklar. Bu karar 2 Kasım'da OpenSSL 0.9.8l çıkmadan üç gün önce belirlendi. Iş parçacığı açıkça / ne zaman düzeltme OpenSSL için uygulanmış, ancak ben m-beta changelog bu girdi kapsamında olduğunu düşünüyorum 0.9.8m, sabit olacağını tahmin bir şey olduğunu belirtmez:

*) Durum bilgisi olmayan oturum sürdürme işlemine yönelik düzeltmeler. Sunucu adı işleme sırasında değiştiğinde biletleri düzenlerken ve şifresini çözmeye çalışırken initial_ctx kullanın. Durum bilgisi olmayan oturum yeniden başlatmayı denerken sıfır olmayan bir oturum kimliği kullanın: bu, el sıkışma yerine sunucu merhaba alındıktan hemen sonra (OpenSSL'deki birkaç yer bunu açıkça kabul eder) bir yeniden başlatma olup olmadığını belirlemeyi mümkün kılar.

ORİJİNAL POST

Gentoo'da Apache-2.2.14'te benzer sorunlar yaşıyorum. Referans olarak, USE bayraklarım:

[ebuild   R   ] dev-libs/openssl-0.9.8l-r2  USE="zlib -bindist -gmp -kerberos -sse2 -test" 4,082 kB
[ebuild   R   ] www-servers/apache-2.2.14-r1  USE="ssl -debug -doc -ldap (-selinux) -static -suexec -threads" APACHE2_MODULES="actions alias auth_basic auth_digest authn_dbd authn_default authn_file authz_default authz_groupfile authz_host authz_user autoindex dav dav_fs dav_lock dbd deflate dir env expires headers include info log_config logio mime mime_magic negotiation proxy proxy_balancer proxy_connect proxy_http rewrite setenvif status unique_id userdir -asis -authn_alias -authn_anon -authn_dbm -authz_dbm -authz_owner -cache -cern_meta -charset_lite -disk_cache -dumpio -ext_filter -file_cache -filter* -ident -imagemap -log_forensic -mem_cache -proxy_ajp -proxy_ftp -speling -substitute -usertrack* -version -vhost_alias" APACHE2_MPMS="prefork -event -itk -peruser -worker" 5,088 kB
[ebuild   R   ] net-misc/neon-0.29.0  USE="expat nls ssl zlib -doc -gnutls -kerberos -libproxy -pkcs11" LINGUAS="-cs -de -fr -ja -nn -pl -ru -tr -zh_CN" 859 kB
[ebuild   R   ] dev-util/subversion-1.6.6  USE="apache2 bash-completion dso nls perl python ruby webdav-neon -berkdb -ctypes-python -debug -doc -emacs -extras -gnome-keyring -java -sasl -test -vim-syntax -webdav-serf" 5,384 kB

İle bu SSLProtocol herhangi bir kombinasyonu ile meydana gelir TLSv1dahil

SSLProtocolKaldırmam için ayarlarsam TLSv1yeni bir hata alırım:

svn: PUT of '/!svn/wrk/0b9f5a96-15aa-11df-ad6a-0f71b873281b/project/trunk/path/btn_Cancel.gif': SSL handshake failed: SSL error: bad decompression (https://svn.mudbugmedia.com)

Bu, bunun yerine "ayrıştırma tlsext" hatasıyla karşılaşacağım yaklaşık olarak aynı zamanda gerçekleşir.


SVN istemcimi 1.6'dan 1.7'ye yükseltmek benim için "ayrıştırma tlsext" sorununu çözdü, @ gabe-martin-dempesy'nin "bu sorunun istemci tarafı OpenSSL kütüphanesindeki bir hatadan kaynaklandığını" önermesini destekledi
— Jared Beck

0

Bu sorun en çok Apache httpd 2.2.12 - 2.2.14 ve OpenSSL 0.9.8f - 0.9.8l'de birden çok SSL etkin VirtualHost kullanılması nedeniyle ortaya çıkmıştır.

Aşağıdaki yama benim için sorunu çözüyor gibi görünüyor.

Sitemizi kullandığınızda şunları okuyup anladığınızı kabul etmiş olursunuz: Çerez Politikası ve Gizlilik Politikası.
Licensed under cc by-sa 3.0 with attribution required.