VSFTPD başlatılamıyor


2

FTP sunucumu başlatamıyorum, üstünü kullanarak kontrol ettim ve görünmüyor. Kullandığımda şunu alıyorum sudo /etc/init.d/vsftpd restart"FTP sunucusunu durdurma: Hayır / usr / sbin / vsftpd çalışıyor; hiçbiri öldürülmedi. Vsftpd. FTP sunucusunun başlatılması: vsftpd."

Çalıştırdığımda sudo vsftpdbu "500 OOPS: config dosyası doğru kullanıcıya ait değil veya bir dosyaya ait değil" alıyorum

sudo chown michael /etc/vsftpd.confÇalıştırdığımda sudo chown michael /etc/vsftpd/vsftpd.confböyle bir dosya hatası alıyorum gibi denedim . Ancak hala sunucuyu başlatamıyorum.

Bunun yanlış yer olduğunu mu soruyorum?

Yanıtlar:


2

root'un vsftpd.conf dosyasının olması gerekiyor

sudo chown root /etc/vsftpd.conf

Sonra tekrar sevice başlatmayı deneyin


Bunu yaptıktan sonra şimdi bu hatayı alıyorum "FTP sunucusunu durdurma: Yok / usr / sbin / vsftpd çalışıyor; hiçbiri ölmedi. Rm: '/var/run/vsftpd/vsftpd.pid' dosyasını kaldıramıyor:" Reddedildi "
— Michael St Clair

1
restartÇoğu komut dosyasında A bir stopişlem gerçekleştirir ve ardından bir startişlem gerçekleştirir. İşlem zaten çalışmıyorsa, hizmeti durdurmaya çalışırken hatalar (listeledikleriniz gibi) alabilirsiniz. İşlem şimdi çalışıyor mu?
— Omnipresence

Hayır, sadece start komutunu denedim ve yeniden başlatmayı deniyorum ve aynı sorunu yaşıyorum
— Michael St Clair

Şimdi bu hatayı alıyorum "FTP sunucusu durduruluyor: Hayır / usr / sbin / vsftpd çalışıyor; hiçbiri ölmedi. Vsftpd."
— Michael St Clair,

1
Koşarken ne olacak sudo /etc/init.d/vsftpd start? Çıktı göremiyorsanız, en azından /var/log/rcvsftp.log adresine giriş yapıyor olmalısınız, böylece bu dosyayı başlatma hakkında bilgi için kontrol edebilirsiniz.
— Omnipresence
Sitemizi kullandığınızda şunları okuyup anladığınızı kabul etmiş olursunuz: Çerez Politikası ve Gizlilik Politikası.
Licensed under cc by-sa 3.0 with attribution required.