Güncellemeden sonra mysql sunucusu başlatılamıyor


9

Bugün sistemi güncelledim ve mysql sunucusunu başlatamıyorum:

Aşağıdaki hatayı alıyorum:

Aug 14 14:32:09 VULTURUS kernel: [ 1996.413190] init: mysql main process (14122) terminated with status 1
Aug 14 14:32:09 VULTURUS kernel: [ 1996.413262] init: mysql main process ended, respawning
Aug 14 14:32:10 VULTURUS kernel: [ 1997.373479] init: mysql post-start process (14123) terminated with status 1
Aug 14 14:32:10 VULTURUS kernel: [ 1997.391012] type=1400 audit(1344947530.964:242): apparmor="STATUS" operation="profile_replace" name="/usr/sbin/mysqld" pid=14156 comm="apparmor_parser"
Aug 14 14:32:11 VULTURUS kernel: [ 1997.453824] type=1400 audit(1344947531.028:243): apparmor="DENIED" operation="open" parent=1 profile="/usr/sbin/mysqld" name="/media/WESYS_DATA/MySql_LX/" pid=14160 comm="mysqld" requested_mask="r" denied_mask="r" fsuid=115 ouid=0
Aug 14 14:32:11 VULTURUS kernel: [ 1997.456707] init: mysql main process (14160) terminated with status 1
Aug 14 14:32:11 VULTURUS kernel: [ 1997.456775] init: mysql respawning too fast, stopped

Ancak zaten /etc/apparmor.d/usr.sbin.mysqld dosyasına istisna ekledim

# vim:syntax=apparmor
# Last Modified: Tue Jun 19 17:37:30 2007
#include <tunables/global>

/usr/sbin/mysqld {
  #include <abstractions/base>
  #include <abstractions/nameservice>
  #include <abstractions/user-tmp>
  #include <abstractions/mysql>
  #include <abstractions/winbind>

  capability dac_override,
  capability sys_resource,
  capability setgid,
  capability setuid,

  network tcp,

  /etc/hosts.allow r,
  /etc/hosts.deny r,

  /etc/mysql/*.pem r,
  /etc/mysql/conf.d/ r,
  /etc/mysql/conf.d/* r,
  /etc/mysql/*.cnf r,
  /usr/lib/mysql/plugin/ r,
  /usr/lib/mysql/plugin/*.so* mr,
  /usr/sbin/mysqld mr,
  /usr/share/mysql/** r,
  /var/log/mysql.log rw,
  /var/log/mysql.err rw,
  /var/lib/mysql/ r,
  /var/lib/mysql/** rwk,
  /var/log/mysql/ r,
  /var/log/mysql/* rw,
  /var/run/mysqld/mysqld.pid w,
  /var/run/mysqld/mysqld.sock w,
  /run/mysqld/mysqld.pid w,
  /run/mysqld/mysqld.sock w,

  /sys/devices/system/cpu/ r,

  /media/WESYS_DATA/MySql_LX/** rwk,
  /media/WESYS_DATA/MySql_LX/** rwk,

  # Site-specific additions and overrides. See local/README for details.
  #include <local/usr.sbin.mysqld>
}

Yanıtlar:


6

Aşağıdaki iki satır /etc/apparmor.d/usr.sbin.mysqld örtüşmesindedir.

/media/WESYS_DATA/MySql_LX/** rwk,
/media/WESYS_DATA/MySql_LX/** rwk,

Bu satırları aşağıdaki satırlarla değiştirdiğinizde sorununuz çözülmüş olabilir.

/media/WESYS_DATA/MySql_LX/ r,
/media/WESYS_DATA/MySql_LX/** rwk,

1

Benim durumumda, mesaj:

mysql respawning too fast 

Ben syslogorada apparmor kaldırmıştı, ama sunucumu yeniden başlatmayı unutmuştu çünkü orada bulundu .

Sunucumu yeniden başlattıktan sonra, mysql iyi başladı.


0

Benim durumumda Ubuntu güncellemesi sırasında 11.04'den 11.10'a kadar sonsuz döngü meydana geldi (ve kurulum devam etmedi):

Sep 24 21:50:05 soft kernel: [ 4926.795768] type=1400 audit(1380048605.174:160):     apparmor="STATUS" operation="profile_replace" name="/usr/sbin/mysqld" pid=10215    comm="apparmor_parser"
Sep 24 21:50:05 soft kernel: [ 4926.954977] type=1400 audit(1380048605.334:161): apparmor="DENIED" operation="mknod" parent=1 profile="/usr/sbin/mysqld" name="/srv/mysql/soft.lower-test" pid=10219 comm="mysqld" requested_mask="c" denied_mask="c" fsuid=0 ouid=0
Sep 24 21:50:05 soft kernel: [ 4926.955011] type=1400 audit(1380048605.334:162): apparmor="DENIED" operation="mknod" parent=1 profile="/usr/sbin/mysqld" name="/srv/mysql/soft.lower-test" pid=10219 comm="mysqld" requested_mask="c" denied_mask="c" fsuid=0 ouid=0
Sep 24 21:50:05 soft kernel: [ 4927.043602] type=1400 audit(1380048605.424:163): apparmor="DENIED" operation="open" parent=1 profile="/usr/sbin/mysqld" name="/srv/mysql/mysql/plugin.frm" pid=10219 comm="mysqld" requested_mask="r" denied_mask="r" fsuid=102 ouid=102
Sep 24 21:50:05 soft kernel: [ 4927.087869] type=1400 audit(1380048605.464:164): apparmor="DENIED" operation="open" parent=1 profile="/usr/sbin/mysqld" name="/srv/mysql/ibdata1" pid=10219 comm="mysqld" requested_mask="rw" denied_mask="rw" fsuid=102 ouid=102
Sep 24 21:50:05 soft init: mysql main process (10219) terminated with status 1

Çözüm: Ayrı bir pencerede oturum açtım ve

sudo /etc/init.d/mysql stop
sudo /etc/init.d/mysql start

Daha sonra syslog'u takip etti ve kurulumun normal bir şekilde devam ettiğini fark etti.


"Stop" komutu, ütopikten canlıya do-release-yükseltme sistemimin benzer iletilerle syslog'da asılı kalması benim için çalıştı. Mysql güncellemesine zarar verirse hiçbir fikrim yok, ama eğer öyleyse bu sorunla daha sonra ilgileneceğim ...
— Joe

Sitemizi kullandığınızda şunları okuyup anladığınızı kabul etmiş olursunuz: Çerez Politikası ve Gizlilik Politikası.
Licensed under cc by-sa 3.0 with attribution required.