Sudo çalışmıyor: “/ etc / sudoers, uid 1000'e aittir, 0 olmalıdır”


21

Terminal tarafından sudo komutunu yazıp hatayı gösterdiğinizde, Bu nasıl düzeltilir?

sudo: /etc/sudoers is owned by uid 1000, should be 0
sudo: no valid sudoers sources found, quitting
sudo: unable to initialize policy plugin

Yanıtlar:


31

Sahibini tekrar kök dizinine değiştirin:

pkexec chown root:root /etc/sudoers /etc/sudoers.d -R

Veya visudodosyaların genel doğruluğunu sağlamak için komutu kullanın ( @KasiyA sayesinde ):

pkexec visudo

3
Bunu düzeltmenin daha kolay yolu:pkexec visudo
— α Augsнιη

Im bir sorun var ben bir ec2 örneği var ve ben çözüm denedim ve şifre istiyor. Bunu nasıl azaltabilirim?
— david

Bu berbat bir şey; "'Pkexec' programı şu anda yüklü değil. Yazarak yükleyebilirsiniz: sudo apt-get install policykit-1"
— Koen.

@Koen. Ubuntu'ya varsayılan olarak yüklenir (belki bir sunucu veya minimum kurulum konuşmuyorsanız).
— muru

Gerçekten bir sunucu kurulumu, ama tek kullanıcı modunda önyükleme yaparak düzeltti.
— Koen.
Sitemizi kullandığınızda şunları okuyup anladığınızı kabul etmiş olursunuz: Çerez Politikası ve Gizlilik Politikası.
Licensed under cc by-sa 3.0 with attribution required.