Güncellemeden sonra SSH sorunu


9
Setting up openssh-server (1:5.3p1-3ubuntu7) ... 
Creating SSH2 RSA key; this may take some time ... 
Creating SSH2 DSA key; this may take some time ... 
start: Job failed to start

Ssh başlatılamıyor, zaten yeniden yüklemeyi denedi.

SSH sunucusu manuel olarak başlatılır /etc/init.d/ssh start

netstat -nlp TCP bağlantı noktası 22'de hiçbir hizmetin çalışmadığını gösterir


Sorunuzu manuel olarak başlatmayı denediyseniz açıklayabilir misiniz, yani sudo /etc/init.d/ssh startöyleyse, yüklediğinizden farklı bir hata verdi mi? Ayrıca, zaten ssh çalışan bir örneğinin olup olmadığını görmek ve sonucu sorunuza koymak için yüklemek nmapve çalıştırmak isteyebilirsiniz nmap 127.0.0.1.
— Azendale

manuel olarak çalıştırmayı denedim ve aynı şeyi aldım
— Frielspak

Bir kez daha ssh daemon'u manuel olarak başlatmaya çalışın /var/log/authve dosyanın altındaki kayıtların ne gösterdiğini kontrol edin ...
— Pavlos G.

Yanıtlar:


16

Çözümümün doğru olduğundan emin değilim. Ancak, SSH sunucunuzu başlatmak ve ardından sorununuzu daha sonra çözmek istiyorsanız, işte hızlı çözümüm:

start-stop-daemon --start --pidfile /var/run/sshd.pid --exec /usr/sbin/sshd -- -p 22

eğer öyleyse hata göreceksiniz:

Missing privilege separation directory: /var/run/sshd

daha sonra bu eksik dizini oluşturun ve start-stop-daemon komutunun üzerinde tekrar deneyin:

mkdir /var/run/sshd
chmod 0755 /var/run/sshd

bu benim sshd artalanımı başlatmama yardımcı oldu.


1
Bu yalnızca geçerli oturum için düzeltir. Yeniden başlatıldıktan sonra bu dizin kaybolacaktır.
— Malfist

2
/etc/init/ssh.conf dosyasında bölüme başlama öncesi komut dosyasını aşağıdaki satır ekleyin: "mkdir -p -m0755 / var / run / sshd"
— achabahe

4

sshdHata nedeniyle başlatılmayacak aynı sorunu vardı .
Dizin olmadığını gösterdi /var/run/sshd.

ll  /var/run

için bir bağlantı gösterdi /run.
Ama benim sistemimde /runramdisk üzerinde çalışıyor.
Bağlantıyı silindi ve dizinleri yarattı Yani /var/runve /var/run/sshd. Şimdi sshdnormal bir şekilde başlıyor ve sshtekrar sistemime ulaşabiliyorum .


1

güvenlik duvarımı 22 numaralı bağlantı noktasının benim için çalışmasına izin verecek şekilde yeniden yapılandırıyorum.

ufw enable
ufw allow 22

0

Bu davranışa neden olan 3 sorun var gibi görünüyor (benim sistemim için Ubuntu 14.04LTS):

1- ssh bilinmeyen işi, 'su' oturumundan 'service ssh start' komutunu kullanmaya çalıştığınızda oluşur. Çözüm, oturum açmış bir kullanıcının sudo hizmet başlangıcını 'sudo' yapabilen kullanmaktır.

2- Mevcut ssd / ssh betiği sshd başlangıcında sshd'yi başlatmadan sessizce çıkıyor

3- ssh'ın başlamamasının temel nedeni Ubuntu 14.04'te sshd'nin çalıştırılmaması gerektiğini gösteren boş bir dosya / etc / ssh / sshd_host_not_to_run olmasıdır. Sshd'nin çalışmasını istiyorsanız bu dosyayı silin.

Yani genel çözüm: / etc / ssh / sshd_host_not_to_run sildikten sonra sudo service ssh start kullanın


0

Sadece openssh sunucusunu yeniden yükleyin:

sudo apt-get install --reinstall openssh-server

Sitemizi kullandığınızda şunları okuyup anladığınızı kabul etmiş olursunuz: Çerez Politikası ve Gizlilik Politikası.
Licensed under cc by-sa 3.0 with attribution required.