phpmyadmin eksik uzantılar nedeniyle çalışmıyor


20

phpmyadminUbuntu 16.04'te kullanmak üzereyim . Ancak sayfanın çalışmadığını gösterir. hata günlüğü diyorerror 500

PHP Fatal error:  require_once(): Failed opening required '/usr/share/php/php-gettext/gettext.inc' (include_path='.:/usr/share/php') in /usr/share/phpmyadmin/libraries/select_lang.lib.php on line 477

İlk başta mysqli|mysqluzatma eksik olduğunu söylüyor . ama uykusuz saatlerden sonra ne yaptığımı unuttum. Ben php7 kullanıyorum.

Yanıtlar:


45
sudo apt-get install php-mbstring php7.0-mbstring php-gettext

ya da sadece:

sudo apt-get install php-gettext

ve sonra:

sudo service apache2 restart

Bu, bu hata bildirildi:


İlk kez bir sunucu kuruyorum ve op ile aynı sorunu yaşadım, ancak yükseltme yapmadığım için 16.04'ün yeni bir yüklemesiydi. Ancak aynı sorun ve bu sorunu çözdü. Teşekkür ederim!
— Darren Haynes

Teşekkürler, ben de aynı problemi yaşadım, benden +1 çalıştı.
— Zviad Gabroshvili

sudo apt install php-gettextyeterlidir. Bu diğerleri yükler.
— bshea

Bu 18.04 Ubuntu'da çalışmıyor. Başka fikrin var mı?
— EODCraft Ekibi

Buldum onu! Depoyu El İle Eklemelisiniz. askubuntu.com/a/715947/619039
— EODCraft Ekibi

6

Php-gettext'i kurmanız gerekiyor, kullanarak kurun

 sudo apt-get install php-gettext

6

Bu sorunu çözmek için saatler kaybettim. Sadece yükleyin php-mbstring, php7.0-mbstringve php-gettext. Bu kadar.

Bunu aşağıdaki komutu çalıştırarak yapabilirsiniz:

sudo apt-get install php-mbstring php7.0-mbstring php-gettext

Henüz 16.04'ü yüklemedim / denemedim, ancak php7 yüklüyse php-mbstringyüklemenin otomatik olarak yükleneceğini varsayardım php7-mbstring.
— Dan

Belki haklısın; belki bu sadece bir metapacket.
— Mich.

3

Benim durumumda sorunum klasör oluşturma ile oldu. Ben php-gettext lib i yüklerken:

sudo apt-get install php-gettext

İki klasör oluşturulur. usr/share/php

Klasör 1 - usr/share/php/php-gettext
Klasör 2 -usr/share/php/php-phpgettext

Ve ilk klasörün içinde ikinci klasöre bazı sembolik bağlantılar.

İlk klasörü şu şekilde sildim:

sudo rm -r usr/share/php/php-gettext

Ve sonra php-php-gettext klasörünü php-gettext dosyasına kopyalayın:

sudo cp -r php-php-gettext php-gettext

Şimdi işlerim phpmyadmin.



0

Bunu deniyorum:
sudo dpkg-reconfigure phpmyadmin
ve soketi TCP / IP'ye ayarlayın . Sonra
sudo apt-get install php-mbstring php7.0-mbstring php-gettext
sudo service apache2 restart


0

Synaptic Paket Yöneticisi'ni kullanın, yükleyin php7.0-mbstringve yapın sudo service apache2 restart.


0

Phpymadmin'i arşivlerden yüklediyseniz, php-gettext bir bağımlılıktır ve otomatik olarak kurulur.


Sitemizi kullandığınızda şunları okuyup anladığınızı kabul etmiş olursunuz: Çerez Politikası ve Gizlilik Politikası.
Licensed under cc by-sa 3.0 with attribution required.