Ubuntu 11.10'da XAMPP başlatılamıyor


14

XAMPP'yi sudo / opt / lampp / lampp start komutuyla başlatmaya çalıştığımda bana böyle bir mesaj veriyor.

Starting XAMPP for Linux 1.7.7...
XAMPP: Another web server daemon with SSL is already running.
XAMPP: Starting MySQL...
XAMPP: Couldn't start MySQL!
XAMPP: XAMPP-ProFTPD is already running.
XAMPP for Linux started.

Bu nedir ve bunun ne olduğunu SSL ile başka bir web sunucusu arka plan programı nasıl bulabilirim. Bu sunucu nasıl durdurulur?

Yanıtlar:


13

Bu, LINUX'ta XAMPP çalıştırırsanız alacağınız tuhaf bir hatadır.

Varsayım : XAMPP @ /opt/klasörüne sıkıştırılmış .

"XAMPP: SSL ile başka bir web sunucusu arka plan programı zaten çalışıyor" hatasını alırsanız, çalıştırdığınızda ./lampp start. Bu hatadan kurtulmak için aşağıdaki adımları uygulamanız yeterlidir:

  1. Dosyayı açın /opt/lampp/etc/httpd.conf.

  2. Arayın Listen 80ve başka bir bağlantı noktasına değiştirin (örneğin Listen 2145) (Satır No. 40).

  3. Dosyayı açın /opt/lampp/etc/extra/httpd-ssl.conf.

  4. Arayın Listen 443ve başka bir bağlantı noktasına değiştirin (örneğin Listen 16443) (Hat No. 39).

  5. Dosyayı aç /opt/lampp/lampp

  6. Bağlantı noktasını arayın testport 80ve ile değiştirin testport 2145. Ayrıca değiştirmek testport 443için testport 16443. (197, 214 sayılı Hat Olur)

  7. Şimdi git ve koş /opt/lampp/lampp start. Şimdi çalışmalı.

Not: Satır numaraları farklı olabilir.


Tnx bro .. :) Daha önce mahveden sunucuyu durdurmanın bir yolu var mı?
— Asanka400

Bu, hangi sunucuya bağlı olduğuna bağlıdır, eğer herhangi bir daemon işlemi kullanıyorsa, şans daha azdır, önce hangi işlemin bağlantı noktasını varsayılan olarak kullandığını bilmeniz gerekir.
— sum2000

Bu xampp phpmyadmin sayfasında tıklarsanız alıyorum hatadır. Hata MySQL şöyle dedi: Documentation # 2002 - Böyle bir dosya veya dizin yok Sunucu yanıt vermiyor (veya yerel sunucunun soketi doğru yapılandırılmamış).
— Ram

3

Terminalde, yürütün sudo /opt/lampp/lampp disablessl. Bu, ssl'yi devre dışı bırakmalıdır, bundan sonra xampp tekrar başarıyla başlatılır.


Bir cazibe gibi çalıştı. Ancak Xampp'de SSL'yi devre dışı bırakmanın herhangi bir dezavantajı var mı?
— Prabesh bhattarai

2

Benzer bir sorunum var ve sorunun 443 numaralı bağlantı noktasında (SSL) zaten çalışmasına neden olduğunu fark ettim.

Çalışan dinleyici kontrol edin: sudo netstat -tunap | grep LISTEN. Benimki vardı vmware-hostdve cupsdlisteledi.

Http://www.apachefriends.org/tr/xampp-linux.html adresine bakın sudo /opt/lampp/lampp stopssl, SSL desteğini kalıcı olarak devre dışı bırakan komutunu kullanarak lambanın SSL hizmetini kapatmamız gerekir .

Şimdi xampp'i başlatabilirsiniz: sudo /opt/lampp/lampp start


Bağlantı noktalarını 2145 ve 16443 olarak değiştirmek benim için işe yaramadı. Bu yaptı ve ben hiçbir ssl .. teşekkürler
— user568021

0

Ubuntu 16.04 için

  1. Önce komutu kullanın nmap localhostve 434 numaralı bağlantı noktasının çalışıp çalışmadığını kontrol edin.
  2. Çalışıyorsa komutunu kullanın sudo kill $(sudo lsof -t -i:443)
  3. Sonra xampp kontrol panelini açın ve oradan da apache sunucusunu başlatın.
  4. Çalışmaya başlayacak.
  5. Veya şuraya da gidebilirsiniz: /opt/lampp
  6. Sonra komut vererek başlayın ./sudo xampp start

Sonunda işe yarıyor

Sitemizi kullandığınızda şunları okuyup anladığınızı kabul etmiş olursunuz: Çerez Politikası ve Gizlilik Politikası.
Licensed under cc by-sa 3.0 with attribution required.